
5 Basics of CIUMon

5.1 Overview

With a connection to your CIU, Hyperview can:

display current values on CAD sheets and graphics• 
display selected block values in annotations on any document• 
track selected block values and graph them• 
display the status of selected modules• 
display values from any part of your system with a connection to a CIU on any loop• 

Hyperview gets live data through CIUMon. CIUMon handles all communication with the CIU. It provides live
data over your network, and can provide live data to multiple users at the same time.

CIUMon cannot provide live data from a PI system, although information about your PI system can be
included in your project.
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5.1.1 Technical requirements

CIUMon is an interface program that provides read-only access to a CIU interface, via TCP/IP. This program
conforms to the specification provided by the Enhanced Computer Interface Unit Programmer's Reference
Manual, INFI 90 E93-905-9, with extensions that we have discovered. CIUMon can run on Windows 7,
Windows 2008 R2, as well as all later versions of Windows. (For older versions of Windows such as
Windows XP, Windows NT4, or Windows 2000, we can provide archived versions of CIUMon that will work
but do not have the latest features.) The requirements to run CIUMon are as follows:

The host and client computers must be running a TCP/IP stack.• 
For Windows PCs, the preferred operating system and stack is the native Microsoft Network that is
provided with Microsoft Windows operating systems.

• 

CIUMon allows you to collect live data from your plant loop:

CIUMon uses the maintenance interface available to your EWS, which is polled. It can fetch 10-20
values per second.

• 

CIUMon cannot replace a console, as it has no access to exception reports, alarms or history.• 
You can increase throughput with multiple SPMs, or by using RoviSys Turbo.• 
CIUMon keeps track of the incoming requests from all clients. If a data request comes in while there
is still an outstanding one on the CIU for the same block, CIUMon will not send the request again.
Instead, when CIUMon receives an answer to its original request, it will then send that value back to
all clients that requested that particular piece of information.

• 

CIUMon communicates via UDP (User Datagram Protocol)

UDP is a data unreliable connectionless protocol• 
Its robustness and tolerance of network connection problems that may be encountered make it ideal
for use in CIUMon

• 

It reduces the likelihood of errors that may come with more complicated communication protocols• 

5.2 Methods of connecting CIUMon to a CIU

Once CIUMon is installed, decide which method of connecting to a CIU is appropriate for your setup. Then,
connect to your CIU either directly, through RoviSys Turbo, or through Harmony OPC Server. Finally, set up
CIUMon to run automatically.

CIUMon can be connected directly to some types of CIU.
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For other types of CIU, CIUMon must be connected through RoviSys Turbo.

Connecting through RoviSys Turbo also allows a CIU to be shared between CIUMon and other programs,
such as WinCAD or Composer.

RoviSys Turbo can be connected via serial port or via ethernet to an IET800 or PNI800 ethernet CIU. This
lets DBDOC take advantage of RoviSys Turbo's turbo mode features. Contact us for instructions on how to
set this up.

Alternatively, you can create special DBDOC blocks in Harmony OPC Server to allow DBDOC to connect to
an IET800 ethernet CIU over your network. (However, because this method does not allow you to use
RoviSys Turbo's turbo mode features, it will typically provide less throughput than using RoviSys Turbo to
connect either to the ethernet CIU or to another serial or SCSI CIU.)

5.3 Connecting to a CIU
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To connect directly to a CIU:

On the Options menu, click CIUMon Settings. Choose a UDP port, and select your CIU type.1. 
Click the Communication Modes tab, and click Connect directly through serial port.2. 
Click the Comm and Flow Control Settings tab, and select the serial port connected to the CIU in
the Serial Port list.

 Note: If EWS software, such as Composer or WinCAD, is set up on the same computer, then you
may wish to move the serial connection to a different COM port. This way you do not have to change
any settings in the EWS software, but that software and CIUMon are not trying to access the same
port.

3. 

If you know that any of the other settings need to be changed for your setup, change them now.
Usually the defaults are fine.

4. 

Click OK to close the Options window. Then, make sure you can get data from your CIU.5. 

5.3.1 Choosing a port to get data from CIUMon

On the Options menu, click Settings. Click the Configuration tab.1. 
In the UDP Port box, type the UDP port for CIUMon to use.

 Note: Usually, the default port 5099 should be used. But if multiple instances of CIUMon will be
running on the same computer, they must use different UDP ports. CIUMon will warn you if you try to
set a port that matches what is already in another configuration.

2. 

Make a note of the UDP port that you've chosen. You will need this number in order to configure
Hyperview to get live data.

3. 

Click OK to close the Options window.4. 
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5.3.2 Configuring CIUMon for your CIU type

On the Options menu, click CIUMon Settings. Click the Configuration tab.1. 
In the CIU Type box, click your CIU type.2. 
If any of the following special situations apply, change the settings as needed:

If you are connecting to a serial port module (SPM01 or SPM02), type the loop number in the
Loop box and the PCU number in the PCU box. These parameters tell CIUMon which Loop
and PCU the serial port module is connected to.

CIUMon will send an environment fetch to get the loop and PCU from an SPM02,
but the fetched loop and PCU will be meaningless. CIUMon must use the specified
loop and PCU to know what requests to send to the serial port module.

◊ 

♦ 
3. 

Click OK to close the Options window.4. 

5.3.3 Connecting to a TRAX emulator
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On the Options menu, click Settings.1. 
Click the Communication Modes tab.2. 
Click Connect to a TRAX CIU emulator.3. 
Type the IP address of the computer running the Trax emulator in the TRAX computer name or IP
address box.

4. 

 Note: When you disconnect CIUMon or another program from the Trax emulator, you will need to wait for
approximately four minutes before you can connect to the emulator again. This is because of how Trax
handles its network sockets.

5.3.4 Making sure you can get data from CIUMon

Once you have configured CIUMon to connect to your CIU, you should test it to make sure your configuration
works. The best end-to-end test is to connect Hyperview and make sure you can get data.

If the Options window is still open, click OK to close it.1. 
On the File menu, click Connect. CIUMon should display some information, including your CIU's
ring and node. The word "OK" should appear in green, on a line by itself.

2. 

Using Hyperview, check to make sure you can access live data. See Live Data Configuration in
Hyperview and Displaying Slow Mode live data in Hyperview.

3. 

Once CIUMon is connected to your CIU, you may wish to:
Run CIUMon automatically (as a service)♦ 
Build the connection settings into your project♦ 

4. 

5.3.5 Running CIUMon manually

Most of the time, you should run CIUMon automatically. However, there may be occasions where you need
to run it manually.
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To run CIUMon manually:

Start CIUMon. On the Start menu, point to All Programs, then point to GMCL DBDOC, and then
click Start CIUMon Online Data Server.

1. 

If you have more than one configuration, CIUMon will ask you to choose which configuration you
want to load. Select the appropriate configuration, and click OK.

2. 

CIUMon may connect automatically, if it is configured to do so. (To configure CIUMon to connect
automatically: On the Options menu, click Settings; and then select "Auto Connect".) If it does not
connect automatically, then on the File menu, click Connect.

3. 

 Note: If you are running CIUMon as a service, you will not be able to run the same configuration manually
unless you stop the service first.

When CIUMon is run manually or interacting with the desktop, you can use the CIUMon menus to interact
with CIUMon.

You can use the menus to connect or disconnect from the CIU, clear the displayed messages, check the
connection status, or change CIUMon's settings.

To connect to the CIU:

On the File menu, click Connect.• 

To disconnect from the CIU:

On the File menu, click Disconnect.• 

To clear the displayed messages:

On the File menu, click Clear Window.• 

To change CIUMon's settings:

On the Options menu, click CIUMon Settings.1. 
Change the settings as needed.2. 
To make the changes permanent, save the configuration.3. 

5.4 Connecting to RoviSys Turbo
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Follow these steps to connect DBDOC to your CIU using RoviSys Turbo:

Install RoviSys Turbo on a computer that connects to a CIU.1. 
Connect RoviSys Turbo to your CIU.2. 
Connect CIUMon to RoviSys Turbo.3. 
Set up RoviSys Turbo to accept connections from any programs CIUMon is sharing the CIU with
(such as WinCAD or Composer).

4. 

 Note: These instructions are for RoviSys Turbo version 7.2 or later. If you are using an older version of
RoviSys Turbo, we recommend you upgrade. If you must connect CIUMon to an older version of RoviSys
Turbo, contact us for instructions.

5.4.1 Installing RoviSys Turbo

A trial version of RoviSys Turbo is included with DBDOC. The installer for the trial version is located in either
C:\Program Files\DBDOC\PROGRAMS\RoviSys\ or C:\DBDOC\CIUMON\Programs\RoviSys\,
depending on how CIUMon was installed.

 Note: The RoviSys Turbo demo will run for up to one hour at a time, and it can be configured to allow for
a one-time 45-day trial. The demo on the DBDOC install DVD might not be the most recent version. To get
the newest and best version of the demo, download it from http://www.rovisys.com. There is a link to the
RoviSys Turbo demo download page on https://www.gmcl.com/downloads.php.

To continue using RoviSys Turbo, you will need to purchase a license from RoviSys. Please contact us for
information. You may also contact RoviSys directly through their web site at http://www.rovisys.com.

 Note: You may need to uninstall the demo version of RoviSys Turbo when upgrading to the full version.
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Upgrading to a newer version of RoviSys Turbo may also require you to uninstall the old version. Before
uninstalling RoviSys Turbo, we recommend backing up your configuration: in RoviSys Turbo, on the File
menu, click Save As and save a copy of the configuration file to a backup folder.

5.4.2 Connecting RoviSys Turbo to a CIU

On RoviSys Turbo's File menu, click Open. Open DBDOC.cfg, which is in C:\Program Files\OPC90
Server\CFG if RoviSys Turbo is installed in the default location.

1. 

Right-click CIU in the left-hand pane, then click Properties.2. 
In the Primary Port list, click the COM, SCSI, or TCP port that is connected to the CIU.

 Note: If you are using RoviSys Turbo on a computer with EWS software, you might want to move
the CIU to a different port to avoid changing the EWS software configuration.

3. 

Make any other changes you need, in order configure how RoviSys Turbo communicates with your
CIU. Click OK.

4. 

If the CIU is connected to a COM or TCP port, set up that port. On the Edit menu, click COM Ports
or TCP Ports. In the Port list, click the port that is connected to the CIU. Set the baud rate (for COM
ports), IP address (for TCP ports), or other settings needed to connect to the CIU. Click OK.

 Note: RoviSys Turbo COM ports default to 19200 Baud with other settings that are normally
correct. For TCP ports, refer to the Rovisys OPC90 manual for details about how to configure a TCP
connection to an IET800 or PNI800 CIU.

5. 

If you want to log data, right-click CIU and select each of the first four logging options.6. 
On the File menu, click Save.

 Note: If you are using RoviSys Turbo on a computer with User Account Control (UAC) enabled,
you may not be able to save the configuration in the default folder. Choose another folder in which to
save the configuration.

7. 

Start the connection to the CIU to make sure it works: on the View menu, click Monitor. After a
moment, the text "CIU: ONLINE" will appear in the RoviSys Turbo status bar. You must see MyRing
and MyNode having non-zero values, except for Plant Loop, in which case MyRing will be zero.

8. 

To configure RoviSys Turbo's communications with your CIU:

In RoviSys Turbo, right-click CIU in the left-hand pane, then click Properties. The Device
Properties window appears.

• 

For most people using DBDOC, we recommend that you:

Change the Import exception report request rate to 60000 ms, unless you are using OPC tags.• 
Select the Enable Turbo Polling check box.• 
Select the Non-keyed output polling check box.• 
Select the Enhanced Analog Precision check box.• 
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Normally, programs like Composer and DBDOC must get data from your system one block at a time, but
"turbo mode" allows RoviSys Turbo to fetch multiple blocks at once. Using turbo mode, you can get data
more quickly, while reducing the load on your system.

If you are having problems getting data with turbo mode, please contact us for help. We will work with
RoviSys to make sure that you can get data reliably while benefiting from turbo mode's higher speeds and
reduced load on your system. Meanwhile, to make sure that you are always able get data, you can
temporarily disable turbo mode.

To disable turbo mode:

Clear the Enable Turbo Polling box.• 

To enable turbo mode:

Select the Enable Turbo Polling box.• 

Depending on how much data is being asked for, RoviSys Turbo can make multiple requests for data at once
by using different "keyed" requests. However, you can usually get data more quickly if RoviSys Turbo is
making only one request at a time. So, for most situations, we recommend setting RoviSys Turbo to make
only one request at a time by selecting the Non-keyed output polling box.

5.4.3 Methods of connecting CIUMon to RoviSys Turbo

There are two ways to connect CIUMon and RoviSys Turbo:

RoviSys Turbo virtual ports are easy to set up and provide high data rates. If RoviSys Turbo and
CIUMon are on different computers, they can still be connected with RoviSys Turbo virtual ports

• 
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through the network. RoviSys Turbo virtual ports require RoviSys Turbo 7.2 or newer and CIUMon
10.4 or newer.
Serial ports are generally harder to set up and slower. Some system managers may choose to use
serial ports if RoviSys Turbo and CIUMon are on different computers, in order to keep OPC data off
the network. Serial ports can also be used with older versions of RoviSys Turbo and CIUMon.

• 

5.4.4 Connecting to RoviSys Turbo with virtual ports

To connect CIUMon to RoviSys Turbo by using RoviSys Turbo virtual ports:

Configure the virtual ports in RoviSys Turbo1. 
Set up CIUMon to connect to the RoviSys Turbo virtual ports2. 

To set up RoviSys Turbo:
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In RoviSys Turbo, stop the connection to the CIU: on the View menu, clear the Monitor check mark.1. 
Expand CIU in the left-hand pane. Right-click DBDOC, then click Properties.2. 
In the Addressing box, select Virtual port.3. 
In the Port list, select a different port from the one the CIU is using.4. 
Select Read only and Allow R4. Ensure that Prefetch is not selected.5. 
Click OK.6. 
On the File menu, click Save. Then, start the connection to the CIU: on the View menu, click
Monitor.

7. 

To set up CIUMon:

On CIUMon's Options menu, click Settings. Choose a UDP port, and select your CIU type.1. 
Click the Communication Modes tab. Select Connect to RoviSys Turbo and via virtual port
connection.

2. 
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Type the IP address or hostname of the computer running RoviSys Turbo in the RoviSys computer
name or IP address box.

3. 

If you changed the name of the CIU or DBDOC blocks in RoviSys Turbo's left hand pane, change
the Device / MUXCIU block name box to match.

4. 

If you know that any of the other settings need to be changed for your setup, change them now.
Usually the defaults are fine.

5. 

Click OK to close the Options window. Then, make sure you can get data from your CIU.6. 

5.4.5 Connecting to RoviSys Turbo with serial ports

To connect CIUMon to RoviSys Turbo by using serial ports:

Set up a pair of serial ports on your computer1. 
Configure RoviSys Turbo to provide data to one port2. 
Configure CIUMon to connect to the other port3. 

To set up the serial ports:

If RoviSys Turbo is running, exit RoviSys Turbo: on the File menu, click Exit.1. 
Connect two serial ports with a null-modem cable for CIUMon and RoviSys Turbo to communicate
with each other through. RoviSys Turbo will connect to one of these ports, and CIUMon will connect
to the other.

2. 

Write down which ports you set up and which program you plan to connect to each of them.

 Notes:

Very old versions of RoviSys Turbo cannot connect to serial ports above COM9, but you can
use low port numbers for RoviSys Turbo and higher ones for CIUMon in that case.

♦ 

If RoviSys Turbo and CIUMon are on the same computer, and it does not have a 64-bit
operating system, you can use virtual serial ports.

♦ 

If RoviSys Turbo and CIUMon are on different computers or on a computer with a 64-bit
operating system, and there are not enough serial ports, you can add more ports with an
internal interface card or a usb-to-serial converter. Alternately, you can use a third-party
virtual serial port program.

♦ 

3. 

To set up RoviSys Turbo:
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Start RoviSys Turbo.1. 
Expand CIU in the left-hand pane. Right-click DBDOC, then click Properties.2. 
In the Port list, click the port that you set up for Rovisys Turbo. Select Read only and Allow R4.
Click OK.

3. 

On the Edit menu, click COM Ports. In the Port list, click the port that RoviSys Turbo was set to use
in the previous step. Set the baud rate to 57600. Click OK. 115200 is overly vulnerable to ambient
interference and should not be used.

4. 

On the File menu, click Save. Then, start the connection to the CIU: on the View menu, click
Monitor.

5. 

To set up CIUMon:
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On CIUMon's Options menu, click CIUMon Settings. Choose a UDP port, and select your CIU type.1. 
Click the Communication Modes tab. Select Connect to RoviSys Turbo and via serial port.
(Connect directly through serial port can be used instead, but there is some loss of performance
using that option.)

2. 

Click the Comm and Flow Control Settings tab. Select the serial port you set up earlier for CIUMon
in the Serial Port list. In the Baud Rate list, click the baud rate of the serial port connected to the
CIU.

 Note: If you are using virtual serial ports, this setting doesn't matter.

3. 

If you know that any of the other settings need to be changed for your setup, change them now.
Usually the defaults are fine.

4. 

Click OK to close the Options window. Then, make sure you can get data from your CIU.5. 
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5.4.6 Adding serial ports to your computer

RoviSys Turbo may connect to CIUMon or your EWS software through a serial line. To do so, RoviSys Turbo
and the other program must each have a COM port, and these ports must be connected. In many cases, if
RoviSys Turbo and the other program are running on the same computer, they can connect through virtual
serial ports rather than real serial ports.

Instead of using serial ports, CIUMon can connect to RoviSys Turbo using RoviSys Turbo virtual
ports.

• 

On 32-bit platforms, you can connect your EWS software to RoviSys Turbo using virtual serial ports
included with DBDOC.

• 

The included virtual serial ports do not work on 64-bit Windows platforms (including Windows 7). To
add serial ports to one of these platforms, use a usb-to-serial converter, or better, use internal serial
ports on the motherboard or install a PCI serial card. Alternately, you can use a third-party virtual
serial port program.

• 

To set up virtual serial ports:

On the CIUMon Options menu, click Virtual Serial Port Setup. The Virtual Port Setup program will
open.

1. 
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On the Virtual Port Setup Options menu, click VSP Configuration.2. 
In the Virtual Serial Port Creation list, click any port. Hold down CTRL and click a second port.
Click Create Now. The two ports that were selected will disappear from the Virtual Serial Port
Creation list and appear in the Virtual Serial Port Deletion list.

3. 

Click the Virtual-To-Virtual Connections tab.4. 
In the VSPs Available list, click the first port, then click the second port. Click Add To List. The two
ports will disappear from the VSPs Available list, and the new connection will appear in the
Virtual-To-Virtual Connections list.

5. 

 Note:

The Virtual Serial Port Setup option is disabled on 64-bit Windows platforms (including Windows 7).
Also, they do not work on Windows 8. To add serial ports to 64-bit Windows, use a usb-to-serial
converter. Alternately, you can use a third-party virtual serial port program.

• 

If you have not run Virtual Port Setup before, it will be installed when you try to run it. You will then
be prompted to reboot the computer.

• 

The first time you set up and try to use virtual serial ports after installing them and rebooting the
computer, you may see an Error: COMx.Read (), code 87 message in the Virtual Port Setup
window. If this occurs, reboot your computer again -- the virtual serial ports should work fine after this
second reboot.

• 

If you get a Could not find OEM file error after your computer reboots, copy the file "vsp.oem" from
the folder where CIUMon is installed to the system32 subfolder of your computer's Windows folder.

• 

If you later install more physical serial ports, you should delete all of the virtual serial ports and
connections first, then re-create them after the new physical ports are installed and working.

• 

To remove virtual serial ports:

In Windows Explorer, browse to the Programs folder in your installation directory (this is usually in
either C:\Program Files\GMCL\DBDOC or C:\DBDOC\CIUMON).

1. 

Double-click VSPCleanup.exe and follow the instructions.2. 
If the computer was not rebooted in the previous step, reboot it now.3. 

To set up internal serial ports:

If you are installing a new interface card to add serial ports, you will have to power down the
computer and open it up. Identify an unused slot of the type required by the card and remove the
corresponding cover from the back of the case. Depending on the number of ports supported by the
card, you may also have to connect a serial port header to the card and install it in another unused
opening in the back of the case.

1. 

Identify the serial ports you've installed:
Right-click the My Computer icon on the desktop, and then click Properties.1. 
Click the Hardware tab, then click the Device Manager button.2. 
Expand the Ports (COM & LPT) entry. The serial ports should each be listed as
Communications Port (COMn) or mumble Serial Port (COMn), where n is the port
number and mumble is some descriptive text.

3. 

2. 

Connect two ports with a null modem cable, to provide a connection between them.3. 
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To set up a usb-to-serial converter:

Plug the converter into an available USB port on your computer.

After a short delay, Windows will recognize and install the converter. When it has finished installing
the converter, it will display a message in the system tray.

1. 

Check that it is installed correctly:
Right-click the My Computer icon on the desktop, and then click Properties.1. 
Click the Hardware tab, then click the Device Manager button.2. 
Expand the Ports (COM & LPT) entry. The new serial ports should each be listed as USB
Serial Port (COMn), where n is the port number.

3. 

2. 

Connect two ports with a null modem cable, to provide a connection between them.3. 

 Note: GMCL has USB-to-serial converters available for sale. Please contact us for details.

A note about USB-to-serial converters and Windows 7:

On Windows 7 and Windows 2008 Server, USB-to-serial converters do not work as well as internal serial
ports. They are slower and have higher error rates. In some cases, they may not work at all. You should use
internal serial ports if possible. Alternately, you can use a third-party virtual serial port program.

If you do use USB-to-serial converters on Windows 7 and 2008 Server, do not use speeds above 115200
bps.

If Windows 7 or Windows 2008 Server does not automatically install your USB-to-serial converter, you will
need to download drivers from the converter manufacturer's website. The drivers for the USB-to-serial
converters sold by GMCL are available at http://www.vscom.de/616_download.htm.

Third-party virtual port alternatives:

As an alternative to RoviSys Turbo virtual ports, the virtual serial port software included with DBDOC, or
physical serial ports, you can use a third-party virtual serial port program to connect CIUMon or your EWS
software to RoviSys Turbo.

These software packages can create virtual serial ports for CIUMon or your EWS software to use for
connecting to RoviSys Turbo:

The com0com null-model emulator is an open source virtual serial port driver that supports both
32-bit and 64-bit versions of Windows. Note that to use this program with 64-bit Windows, you will
need a signed version of the com0com driver. Contact us for information about obtaining a signed
version of the driver.

• 

The Eltima Virtual Serial Port Driver is a commercial software package that can create virtual serial
ports. It supports both 32-bit and 64-bit versions of Windows.

• 
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5.4.7 Connecting other programs to RoviSys Turbo

If you are using RoviSys Turbo to share a serial connection to a CIU between CIUMon and EWS software
(such as Composer or WinCAD), you can avoid changing the EWS software settings with the following
strategy:

Move the CIU connection to a different serial port, and connect RoviSys Turbo to that serial port.1. 
When you set up RoviSys Turbo to accept connections from the EWS software, connect a null cable
between the serial port that the CIU was connected to and a third serial port.

2. 

Then, have RoviSys Turbo use the third serial port to communicate with the EWS software. The
EWS software will connect to RoviSys Turbo through the null cable, using the same port as before.

3. 

A side benefit of this approach is that you can reconnect the CIU directly to the EWS simply by moving the
cable back. If the computer does not have the extra serial ports you need for this approach, you can add
serial ports with an internal interface card or a usb-to-serial converter.

To connect other programs to RoviSys Turbo:

If RoviSys Turbo is running, exit RoviSys Turbo: on the File menu, click Exit.1. 
Set up two connected (real or virtual) serial ports for RoviSys Turbo and the other program to
communicate with each other through. Write down the two port numbers. RoviSys Turbo will connect
to one of these ports, and the other program will connect to the other one.

 Note: If you moved the CIU connection so you wouldn't have to change settings in the EWS
software, then use a connection between the serial port it was originally using and another real serial
port.

2. 

Start RoviSys Turbo and open the saved configuration.3. 
Right-click CIU in the left-hand pane, then click New Block.4. 
Type a name for the block in the Name box (e.g. WinCAD).5. 
In the Block Type list, click MUXCIU.6. 
In the Port list, click the port that you set up for RoviSys Turbo. Click OK.7. 
On the Edit menu, click Ports. In the Port list, click the port that you set up for RoviSys Turbo again.
Set a baud rate that your EWS software supports (typically 19200). Click OK.

8. 

Start the connection to the CIU: on the View menu, click Monitor.9. 
Set up the other program to connect to the port you set up for it.10. 

 Note: WinCAD and Composer have been tested to work when connected to a Rovisys Turbo MUXCIU
block as described here. Conversely, while S+ Engineering tools may have basic functionality, some
functions such as firmware and program downloads will not work, and so Rovisys does not officially support
connecting to S+ Engineering tools in this way. Therefore, if you have the option it would be best practice to
have a separate, dedicated CIU to use with S+ Engineering tools instead of attempting to multiplex it with
DBDOC using Rovisys Turbo.
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5.5 Connecting to Harmony OPC Server

DBDOC can connect to HAOPC 6.0 or later. This can allow you to get data from an IET800 ethernet CIU. To
do this:

Configure the Harmony OPC Server by adding three DBDOC tags. To do this, you will:
Generate Harmony OPC backup configuration files♦ 
Modify those files by adding three DBDOC tags♦ 
Upload your changes to the configuration♦ 

1. 

Set up CIUMon to connect to the Harmony OPC Server.2. 

Generate backup configuration files:

You will need to edit your Harmony OPC backup configuration files in order to add DBDOC tags. If you do
not already have these configuration files, use these steps to generate them.

Start the HOPC Online Utility: On the Start menu, under Programs, click ABB Symphony Plus,
then click Harmony OPC, and then click HOPC Online Utility.

1. 

In the HOPC Online Utility window, on the Configuration menu, click Backup Configuration.
Choose a folder where you would like to save the backup configuration files.

2. 

When the backup completes, click OK. Then, close the HOPC Online Utility program.3. 

Add DBDOC tags to your configuration files:

Start the HOPC Offline Utility: On the Start menu, under Programs, click ABB Symphony Plus,
then click Harmony OPC, and then click HOPC Offline Utility. Then, on the File menu, click Load
and choose to load the backup configuration files that you previously saved.

1. 

Add tags to your configuration: On the Edit menu, click Add. You will need to add three tags:
A tag with the Tag Type "BLOCKOUTPUT" and Tag Name "DBDOC_OUTPUT", for loop 0,
node 0, module 0, block 1.

♦ 

A tag with the Tag Type "BLOCKTUNE" and Tag Name "DBDOC_TUNE", for loop 0, node
0, module 0, block 1.

♦ 

2. 

198

http://wiki.gmcl.internal/w/File:CM_help_-_HOPC_-_BLOCKOUTPUT.png


A tag with the Tag Type "BLOCKMODSTATUS" and Tag Name "DBDOC_MODSTAT", for
loop 0, node 0, module 0, block 0.

♦ 

After adding the three tags, click the Verify button to make sure the changes are valid.3. 
Click the Save button to save these tags. Then, click Exit.4. 

Upload your changes to the configuration:

Start the HOPC Online Utility: On the Start menu, under Programs, click ABB Symphony Plus,
then click Harmony OPC, and then click HOPC Online Utility.

1. 

On the Tools menu, click Apply Tag Configuration. Load the backup configuration file that you
modified by adding the three DBDOC tags.

2. 

Click the Verify button. The HOPC Online Utility should show that three changes are detected. Then,
click Apply to load and merge your changes onto the HOPC server.

3. 

Close the HOPC Online Utility program.4. 

Set up CIUMon to connect to Harmony OPC Server:

In CIUMon, on the Options menu, click Settings.1. 
Click the Communication Modes tab. Select Connect to Harmony OPC Server.2. 
Select the appropriate server instance for CIUMon to connect to.3. 
Type the IP address or hostname of the computer running Harmony OPC Server in the Harmony
OPC computer name box.

4. 

Click OK to close the Options window. Then, make sure you can get data from your CIU.5. 

199

http://wiki.gmcl.internal/w/File:CM_help_-_HOPC_-_BLOCKTUNE.png
http://wiki.gmcl.internal/w/File:CM_help_-_HOPC_-_BLOCKMODSTATUS.png
http://wiki.gmcl.internal/w/Making_sure_you_can_get_data_from_CIUMon


5.6 Managing CIUMon configurations
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CIUMon can store different configurations. This is especially useful if the computer running CIUMon is
connected to multiple CIUs, since it allows a separate configuration to be stored for each CIU. These
configurations can be used to run multiple copies of CIUMon connecting to different CIUs, or to change
which CIU a single copy of CIUMon is connected to.

Current versions of CIUMon store configurations in the registry. Older versions of CIUMon stored settings in
a file in the Windows directory. The first time a newer version of CIUMon is run, it will convert old settings to a
configuration called "Configuration 1", which will be loaded automatically.

On startup, CIUMon will attempt to load the configuration that was opened last. If that configuration is already
in use, it will open the CIUMon Configurations window so that you can select another configuration.

To keep your configurations organized, use CIUMon's configuration management tool to identify unused
configurations that can be hidden or deleted.

5.6.1 Loading, saving, and deleting configurations

To save a configuration:

On the File menu, click Save Configuration.1. 
In the "Save Current Configuration As" box, type a name for the configuration.2. 
Click OK.3. 

To load a configuration:

On the File menu, click Load Configuration.1. 
In the Select the configuration that you wish to load box, click the configuration to load. Or, click
(New DCS Configuration) to load CIUMon's default settings for connecting to a CIU. Use (New
Relay Configuration) only if you are setting up CIUMon in relay mode or collector mode.

2. 

To see what settings are in the configuration before loading it, click Preview Settings.3. 
Click OK.4. 

To delete a configuration:

On the File menu, click Delete Configuration.1. 
In the Select the configuration that you wish to delete box, click the configuration you want to
delete. You can select several configurations to delete at the same time.

2. 

To see what settings are in the configuration before deleting it, click Preview Settings.3. 
Click Delete.4. 

 Note: If you delete the currently loaded configuration, you will be prompted to confirm first. After closing
the dialog, you will be prompted to choose another configuration to load.

 Note: You can also use CIUMon's configuration management tool to delete configurations.
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5.6.2 Keeping your configurations organized

Use CIUMon's configuration management tool to keep your configurations organized, by identifying unused
configurations and hiding or deleting them.

To use this tool: On the File menu, click Manage Configurations.

To identify unused configurations:

Each UDP port and serial COM port on your computer can only connect to one program at a time. So, if you
have two CIUMon configurations that are both using the same UDP port or COM port, you cannot use them
both at once. Usually, in this situation, one of the configurations will be the one you are currently using, while
the other is unused: for example, the unused configuration might be an old configuration that is no longer
relevant, or it might simply have been created by accident.

To identify configurations that share a UDP or COM port: In the Sort configurations by box, select one of
the following.

UDP Ports. This will show you which configurations are using each port to receive requests for data.
You can easily see if there are multiple configurations that all use the same port. Since every
CIUMon configuration must use a UDP port to receive requests, all of your configurations will appear
somewhere in this list.

• 

Serial COM ports. This will show you which configurations use each COM port to communicate with
the CIU. Some configurations may not use COM ports ? for example, you might have configurations
that connect to a TRAX emulator, to a Harmony OPC server, or to RoviSys Turbo by using a virtual
connection. These configurations will not appear in the list when you choose to sort by Serial COM
ports.

• 

Collector Ports. This will show you which collector receiver configurations are using each port to
listen for data from the upstream CIUMon. Only relay configurations that are set up as collector
receivers will appear in this list.

• 

Serial Port Module Loop/PCU. If you have configurations configured to connect to a serial port
module (SPM01 or SPM02), this will show you which configurations are set up for each loop and
PCU.

• 

Configurations with/without conflicts. This will show you all of the configurations that share a
UDP port, COM port, collector port, or serial port module loop/PCU with some other configuration.

• 
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Click Preview Settings or double-click on any configuration to see exactly what is being used and by
which configurations.
Configurations with/without services. Configurations that are actively in use may have services
set up to run them automatically. So, the configurations without services displayed in this list are
more likely to be unused.

• 

If you have two or more configurations that share a UDP or COM port, only one of those configurations will
be able to connect at a time. So, the others might be unused. Use these techniques to determine which
configurations are unused.

To view the settings for any configuration: Click Preview Settings; or double-click on the
configuration. The preview window displays all of the options for the configuration, as well as a list of
other configurations that share a COM or UDP port.

• 

Use the "Service" column in the list to see which configurations have services set up to run them
automatically. Configurations that have services associated with them are also displayed in green.
Configurations without services might be more likely to be unused.

• 

To hide or delete unused configurations:

To hide unused configurations. Click on the configuration you want to hide, and click Make
Inactive. You can hold down shift or ctrl to select multiple configurations and hide them all at the
same time. CIUMon will not load inactive (hidden) configurations and you will not see them in the
Save Configuration or Load Configuration windows, but you can restore them if you would like to use
them again.

• 

To view inactive configurations. Select the Show Inactive Configurations box. You can identify
which configurations are inactive by using the Inactive column in the list. Inactive configurations will
also be displayed in grey. Alternatively, in the Sort configurations by box, select Active/Inactive
Configurations to get a list of all inactive configurations.

• 

To restore inactive configurations. Select the configuration you want to restore and click Make
Active.

• 

To permanently delete unused configurations. Click on the configuration you want to delete, and
click Delete. You can hold down shift or ctrl to select multiple configurations and delete them all at
the same time.

• 

5.7 Getting live data across a network

DBDOC can provide read-only live data across most network setups.
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5.7.1 Getting live data through a firewall

By default, CIUMon listens on UDP port 5099. In order to connect to CIUMon from across a firewall, this port
must be unblocked to allow UDP communication.

To avoid having user connections that must be allowed through the firewall, CIUMon can be run in relay
mode or collector mode on a computer outside the firewall. This CIUMon connects to the main CIUMon
through the firewall, and live data users connect to the relay or collector mode CIUMon.

If your firewall rules require the upstream CIUMon to initiate all communications, you may use collector mode
instead of relay mode. As in relay mode, CIUMon will accept requests for data to pass along to an upstream
CIUMon. In collector mode, however, CIUMon does not initiate any communication with the upstream
CIUMon; instead, it waits for that CIUMon to ask for requests.

By default, in relay mode the firewall would need to be configured to allow the relay CIUMon to communicate
with UDP port 5099 of the upstream CIUMon. In collector mode, the firewall would need to be configured to
allow the upstream CIUMon to communicate with UDP port 6099 of the relay CIUMon. Note that the direction
of traffic, and which computer is the one listening, changes depending on the mode. Also, the default port is
different in collector mode -- this is because the relay CIUMon also listens for Hyperview requests on port
5099 by default, so a different port needs to be chosen for communication with the upstream CIUMon.
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However, you can easily configure CIUMon to use other port numbers instead of these defaults.

5.7.2 Getting live data across an intermediate LAN with relay mode

Some networks have an intermediate LAN so that computers on the business LAN can access the historian
computer, but not the DCS LAN. Relay mode or collector mode can be used in these setups to allow users
on the business LAN to access live data in DBDOC.

5.7.3 Getting live data directly from a business LAN

In some setups, it may be acceptable to run CIUMon on a server on your business LAN and connect it to a
read-only RoviSys Turbo port on the DCS LAN through a serial line. RoviSys Turbo connects to the CIU and
sends data back to the CIUMon on the business LAN. Because this setup uses a RoviSys Turbo read-only
port, no changes to the DCS LAN or the plant can be made from the business LAN.

5.7.4 Running CIUMon in relay mode

In relay mode, CIUMon will send requests for data along to an upstream CIUMon, and pass back the
responses. If there is a firewall between your users and the upstream CIUMon, you need only configure the
firewall to allow the relay mode CIUMon to pass requests through it on a single UDP port, and this will allow
all of your users to get data by communicating with the relay mode CIUMon. If your firewall rules require the
upstream CIUMon to initiate all communications, you may use collector mode instead.

To run CIUMon in relay mode:

Load a new relay configuration: on the File menu, click Load Configuration. Then, select "New
Relay Configuration" and click OK.

1. 

On the Options menu, click Settings.2. 
Click Relay mode.3. 
Type the IP address of the CIUMon that you want to connect to in the Computer name or IP
address of upstream CIUMon box.

4. 
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If you have changed the UDP port for the CIUMon you want to connect to, specify the port in the UDP port of
upstream CIUMon box.

Once you have configured CIUMon to run in relay mode, save your configuration and make sure you can get
data from your CIU.

 Note: In the display of the upstream CIUMon that is connected to the CIU, requests that come from the
relay mode CIUMon will have the IP address of the relay mode CIUMon. However, the logon name will be
the user who is using the data.

5.7.5 Running CIUMon in collector mode

In collector mode, CIUMon will wait for an upstream CIUMon to ask if there are any requests for data. Then,
it will reply to the upstream CIUMon to send along any requests. If there is a firewall between your users and
the upstream CIUMon, you need only configure the firewall to allow the upstream mode CIUMon to
communicate through it on a single UDP port, and this will allow all of your users to get data by
communicating with the collector receiver CIUMon. The collector receiver CIUMon does not initiate any
communication with the upstream CIUMon; it waits for that CIUMon to ask for requests. If your firewall rules
do not require the upstream CIUMon to initiate communications, you may use relay mode instead.

To set up the upstream CIUMon:

Start CIUMon on the upstream computer that is connected to your CIU.1. 
If CIUMon is connected, disconnect it: on the File menu, click Disconnect.2. 
On the Options menu, click Settings. Click the Collector Source tab. Select Act as collector
source, and type the IP address of the computer where you want to set up CIUMon in collector
mode. You may also select which UDP port will be used to communicate with the collector receiver
CIUMon.

3. 

Click OK, and save your configuration. Then, connect CIUMon: on the File menu, click Connect.4. 

To set up the collector mode CIUMon:

On the computer where you want to run CIUMon in collector receiver mode, Start CIUMon and load
a new relay configuration: on the File menu, click Load Configuration. Then, select (New Relay
Configuration) and click OK.

1. 

On the Options menu, click Settings.2. 
Click Collector Receiver. Make sure that the port in the Collector receiver UDP port box matches
the one on the Collector Source tab of the upstream CIUMon.

3. 

Click OK and save your configuration. Then, make sure you can get data from your CIU. Note that it
may take about a minute before you can start getting data, as the collector CIUMon waits for the
upstream CIUMon to establish a connection with it.

4. 
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5.7.6 Is it safe to let everyone on the network access live data?

DBDOC's live data features are read-only. Remote users cannot change anything using DBDOC.

CIUMon does have the ability to restart your CIU, which may be useful in troubleshooting. This ability cannot
be accessed remotely. It can only be used from the CIUMon computer that has a physical connection to the
CIU.

5.8 Running CIUMon automatically (as a service)

Running CIUMon as a service ensures that CIUMon will run if the computer is restarted for any reason. It
also restarts CIUMon after some errors in some circumstances, and allows CIUMon to run without any user
logged in.

5.8.1 Setting up a CIUMon service

If CIUMon connects to your CIU through RoviSys Turbo, set up RoviSys Turbo to run automatically1. 
On the Options menu, click Services.2. 
Click Add A Service.3. 
In the Configuration To Load list, click the configuration that the service will use.4. 
If you like, you can make changes to the name for the service in the Name of Service box, or create
a description in the Description of Service box.

5. 

Make sure that the Allow service to interact with desktop check box is cleared. Clearing this box
causes CIUMon to run silently.

6. 

Click OK.7. 
Click Close.8. 
Close CIUMon and reboot the computer.9. 
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Note: You can also create a service using CIUMonController: in the CIUMonController window, click Add a
Service.

5.8.2 Changing a CIUMon service

There are two types of settings that affect a CIUMon service: the settings in the configuration it is using, and
the settings for the service itself. The different types of settings are changed in different ways.

The service settings can be changed through the Services window.

The logging and statistics options in the configuration can be changed using CIUMon Service Controller.

The other options in the configuration must be changed through CIUMon options.

To use CIUMon Service Controller,

On the Start menu, under Programs, click GMCL DBDOC and then click CIUMon Service
Controller.

• 

Or, in the folder where DBDOC was installed, open the Programs folder and run
CIUMonController.exe.

• 

To change service-only options:

Use the Services window to start or stop a CIUMon service, prevent a service from starting when you reboot,
make a service run in a window, or allow non-administrators to start and stop the service by renaming a file.

Open CIUMon.1. 
On the Options menu, click Services.2. 
In the Current CIUMon Services list, click the CIUMon service to be modified.3. 
Change the service's options.4. 
Click Apply Changes.5. 

Note: You can also modify a service using CIUMonController: in the CIUMonController window, click the
service you want to change and then click Modify Service.
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To log CIUMon messages for troubleshooting:

Start CIUMon Service Controller.1. 
In the list of services, click the service that you want to create logs for.2. 
Click Modify Configuration Options. Choose the options you want. Then, click OK.3. 

 Note: Some options may not be available in CIUMon Service Controller. To access these options, stop
the service and run CIUMon manually. Then, load the appropriate configuration. On the Options menu, click
Settings and then select the Logging Options tab.

To view statistics about who is using live data:

Start CIUMon Service Controller.1. 
In the list of services, click the service that you want to view statistics for.2. 
In the Statistics Options box, click View Communication Statistics or View Usage Statistics.3. 

To change other options:

Start CIUMon Service Controller.1. 
Select the service you are modifying and click Launch in Manual Mode. If the service was running,
it will stop. Then, a CIUMon window will open.

2. 

In CIUMon, change the options as required.3. 
In CIUMon, save the configuration.4. 
Quit CIUMon.5. 
In CIUMon Service Controller, click Start Service to get your service running again.6. 

 Note: If you are using an account without administrator privileges, you may still launch CIUMon Service
Controller and make changes to services. However, when CIUMon Service Controller starts, you will be
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asked for the user name and password of an administrator account.

 Note: Logging options can be changed directly in CIUMon Service Controller. Service options can be
changed without stopping the service.

5.8.3 Error recovery when running as a service

If CIUMon is running as a service and it stops without exiting cleanly (ie it crashes), it will be restarted. This
should prevent live data from being unavailable, and avoids requiring the administrator.

If CIUMon crashes again within 30 seconds, it will not be restarted a second time, as this generally indicates
a problem that requires attention. If this happens, please contact GMCL for further assistance.

5.8.4 How to tell if CIUMon is running as a service

If you are running CIUMon as a service, the CIUMon window will not normally be displayed on your
computer. However, there are still several techniques that you can use to make sure that CIUMon is running
properly.

The best way to make sure that a CIUMon service is running properly is by checking if you can
access live data in Hyperview. See Live Data Configuration in Hyperview and Displaying Slow Mode
live data in Hyperview.

• 

You can also use CIUMon Service Controller to check if your CIUMon service is running. Start
CIUMon Service Controller and check the Current service state in the list of services.

• 

If you have a single CIUMon service, you can use Windows Task Manager to check if it is running.
Press CTRL+SHIFT+ESC to open Windows Task Manager. Click the Processes tab and look for
CIUMON.exe in the list of processes. If CIUMON.exe is not present, then the service is not running.

• 

You can temporarily configure a CIUMon service to interact with the desktop so that a window will
appear when the service is running. However, in this windowed mode, CIUMon will not start until you
log on, and it will stop when you log off. After you are finished troubleshooting, you should turn off
this mode so that CIUMon will run even when you are not logged on.

• 

5.8.5 Running RoviSys Turbo automatically

If DBDOC connects to your CIU using RoviSys Turbo, then in order to run CIUMon automatically, you will
need to run RoviSys Turbo automatically.

Recent versions of RoviSys Turbo can be run as a service. Running RoviSys Turbo as a service ensures that
it is always available, both for CIUMon and for other programs that use it, such as a Composer or WinCAD
EWS computer.

Older versions of RoviSys Turbo can be started automatically by CIUMon instead.

To run RoviSys Turbo as a service:
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Make sure CIUMon will not try to run RoviSys Turbo. In CIUMon, on the Options menu, click
CIUMon Settings.

1. 

Click the Communication Modes tab.2. 
Clear the Launch RoviSys Turbo on start-up check box.3. 
In RoviSys Turbo, on the View menu, click Run as Service.4. 

To run RoviSys Turbo from CIUMon:

On the Options menu, click CIUMon Settings.1. 
Click the Communication Modes tab.2. 
Select Launch RoviSys Turbo on start-up.3. 

 Note:

RoviSys Turbo will usually perform best if it is running at high priority. To make sure that RoviSys
Turbo runs at high priority, click Priority on RoviSys Turbo's Edit menu, and then click High.

• 

Some older versions of RoviSys Turbo do not have a feature to set the priority. For these older
versions, use the Set priority level of RoviSys Turbo box in CIUMon to set RoviSys Turbo's
priority. This feature will only work for these older versions of RoviSys Turbo.

• 

5.8.6 Starting and stopping a CIUMon service with CIUWatcher

CIUWatcher can allow non-administrator users to stop and start CIUMon.

To allow non-administrator users to stop and start CIUMon, CIUWatcher looks for the existence of some file.
When this file is deleted or moved, CIUMon is stopped. When this file is created or replaced in its original
location, CIUMon is started again. By setting CIUWatcher to look for a file that any user can create or delete,
you can allow any user to stop and start CIUMon.

To allow non-administrator users to stop and start CIUMon:

Decide where you will put the file that CIUWatcher will look for. Make sure that it can be moved or
deleted and created by the users you would like to be able to stop and start CIUMon, and not by
other users. Create the file.

1. 

Start CIUMon.2. 
On the Options menu, click Services.3. 
In the Current CIUMon Services list, click the service you would like other users to be able to stop
and start.

4. 

Select Run the service only when this file exists.5. 
Enter the location of the file for CIUWatcher to look for in the box below.6. 
Click Apply Changes. Click Close.7. 
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5.8.7 Removing a CIUMon service

On the Options menu, click Services.1. 
In the Current CIUMon Services list, select the service to remove.2. 
Click Delete Service3. 

Note: You can also remove a service using CIUMonController: in the CIUMonController window, click the
service you want to remove and then click Delete Service.

5.9 Improving CIUMon's performance

There are various methods to improve the performance of CIUMon to make sure you are getting as much live
data as possible and not slowing down the computer running CIUMon too much.

5.9.1 Limitations on how much live data you can get

Each CIU that CIUMon is connected to can provide around thirty values per second. Using RoviSys Turbo
can greatly increase this amount. In many cases, a single CIU can provide enough live data for your users.
This is because Hyperview is set up to use live data as efficiently as possible, and because there normally
are not many users accessing live data all at once. If you need to control access to live data so that the users
who need it most can get it, please look at Managing access to live data. If you need to get more live data,
please look at Getting more live data.

Check your  communication statistics to see how much live data has been requested from your system.
Comparing the amount of data requested to the amount of data sent can indicate whether CIUMon is
providing data quickly enough to meet the needs of your users.

If you find that one or two individual users are using much more data than others, it may be useful to review 
best practices for using DBDOC live data.

5.9.2 Best practices for using DBDOC live data

Because there is  a limit to how much live data you can get in DBDOC, a user who consumes a large amount
of live data resources can greatly reduce the amount of live data available to everyone else. Everyone should
use as much live data as they need in order to make the best use of DBDOC when they are analyzing their
system, but we recommend the following best practices to ensure that users do not use too much live data
when they do not need it.

Check your  communication and usage statistics to see how much live data has been requested from your
system, and to check if there might be any one or two users who are using far more live data than everyone
else. If so, it can be helpful to review how these users are using DBDOC and see if they are following these
best practices.

Ensure that you are not getting data for a block that is offline or that doesn't exist in your system.
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For example, if you are using an out of date .dbdoc file and you try to get data for a sheet that shows
an old block that has since been deleted from your system, that will greatly slow down live data for all
of your users and greatly reduce the amount of live data that DBDOC can produce. This is because
the request for data will stay on the loop until it times out, after about five seconds, so for those five
seconds live data might hang for everyone. If this sort of thing happens repeatedly (for example, if a
user is trying to look at an entire sheet of old blocks that no longer exist in your system), it could
cause live data to become entirely unavailable.

Use the camera to get Hyperview live data instead of the clock.
Using the clock button to get live data uses up roughly 10 times more live data than using the
camera so we recommend that all users should use the camera for most work -- you should only turn
on the clock if you really need it, and you should be diligent about making sure that you turn it off
when you are done with the work that required it. Otherwise, you could be using up as much data as
10 more responsible users.

Close or minimize the Hyperview window when you are finished using it.
If Hyperview is left running on a computer after you are finished with it, it can continue asking for
data. Closing Hyperview when you are done with it, or even just minimizing it, can help a lot to make
sure that Hyperview isn't getting a lot of data that users don't actually need. (Hyperview will not get
on-document data while it is minimized, but it will still get data for the watch window.)

Pause data collection in watch window groups when you are finished with them.
The watch window is mainly intended to be used as a short-term analysis tool -- for most watch
window work, we expect that you will trend data for a few minutes and then analyze what that data is
doing and then turn off the trending in the watch window. (To turn off data collection: on the
**Group** menu in the watch window you can click **Pause All Blocks** to stop getting data for that
watch window group; or as a quicker shortcut you can click the clock icon so that it turns white.) If
you leave a lot of watch window groups running, that can consume a lot of live data. You can use the
watch window to trend blocks for a longer period of time, but the most important thing is to make sure
that you turn it off when you are finished getting the data you need -- otherwise, it will keep getting
data when Hyperview is open, even if the watch window itself isn't being shown. If you need to keep
track of what a block is doing over a very long period of time, or if you want to constantly monitor
something all the time, that is the sort of situation where it is better to use a dedicated historian tool
instead of the watch window.

Be careful when opening multiple Hyperview windows at once.
If you keep opening new Hyperview windows without closing old ones, each Hyperview window
could keep getting data -- once you have a lot of them open, it is easy for Hyperview to be requesting
a lot of data at once.

Turn off Show Live Specs when you are done looking at live specs.
If you are using Show Live Specs and you turn on Live Specs for a lot of blocks, it can take more
data to display the live specs because the live specs don't benefit from OPC90's turbo mode. We
recommend that when you are done looking at live specs, it is best to turn off Show Live Specs to
make sure that you are not getting additional live specs when you don't need them.

5.9.3 Getting more live data

If you are not getting enough live data, there are several actions you can take. To make sure that you are
getting as much data as possible from your current hardware, you should make sure CIUMon is running at
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high priority. You may also wish to adjust CIUMon's timing. As well, make sure that CIUMon is connected at
a baud rate of at least 600.

In addition using RoviSys Turbo can greatly increase the amount of live data you can get.

Making sure CIUMon is running at high priority: CIUMon runs at high priority by default. The only reason
it would run at lower priority is if someone changed the priority deliberately, perhaps to reduce CIUMon's
impact on computer performance. Since lowering the priority can slow down live data, you may wish to raise
the priority again.

To check whether CIUMon is running at high priority:

Press CTRL+SHIFT+ESC. Windows Task Manager will open.1. 
Click the Processes tab.2. 
Locate CIUMON.exe in the list of processes. Look at the Base Priority column for CIUMON.exe. It
should be "High".

 Note: If there is no Base Priority column, then on the View menu, click Select Columns. Select
the Base Priority check box and click OK.

3. 

Adjusting CIUMon's timing: When CIUMon requests data, it first sends a request for the CIU to fetch the
desired value. Usually the data is not ready immediately, so CIUMon has to send a second request for the
CIU to respond with the fetched value. The delay between these two requests is fixed at 50ms and is not
adjustable.

If the data was not returned, then CIUMon retries up to the number of times specified by Number of Retries.
The interval between consecutive requests is set by the Response Retry Delay.

The default Response Retry Delay is 60 milliseconds. In systems where the CIU is used with RoviSys Turbo,
this may be too short. Lengthening the delay can reduce the number of times CIUMon requests each value,
which can improve performance. In other systems, the CIU may have the data ready in less than 110 ms. In
this case, shortening the delay can improve throughput slightly.

To change the response retry delay:

On the Options menu, click Settings....1. 
In the Response Retry Delay box, type the new response retry delay (in milliseconds).2. 

5.9.4 Reducing the impact of CIUMon on computer performance

CIUMon should have less impact on your computer's performance when it is run automatically. When it is run
manually, it will have less impact on performance when it is minimized.

You can also reduce the amount of resources CIUMon uses by lowering it's priority. Lowering the priority will
improve computer performance at the expense of CIUMon performance.
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Changing CIUMon's priority: When CIUMon is run interactively, that is, when it either has been run
manually or has been made to interact with the desktop, you can change the priority with which it runs.

The priority you set will affect all CIUMons that start (or restart) after you change the priority. However, it will
not affect CIUMons that are already running, except the one in which you change the priority.

To change CIUMon's priority:

On the Options menu, click Set Priority.... The Set CIUMon Priority window will appear.1. 
In the list of priorities, click the priority at which CIUMon should run.

CIUMon performs best when it is running at High priority.♦ 
2. 

Click OK.3. 

5.10 Managing access to live data

You may want to manage access to live data because the amount of live data available is limited, or for
security or regulatory reasons.

With DBDOC, you can:

Restrict access to live data;• 
Track who is using live data;• 
Allow some users to get more live data than others.• 

5.10.1 Restricting access to live data
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Because the amount of live data available is limited, it may be useful to restrict access to it. DBDOC provides
two ways to do this: by Windows logon name or by IP address. Do not use both methods at the same time.

Live data access restrictions are not configuration specific. They are shared by every CIUMon and every
configuration running on a given machine.

Blocked users who try to access live data will receive an error message letting them know that they have
been blocked.

Restricting access to live data by Windows logon names: A logon name can be either blocked or
approved. If any logon names are approved, only approved logon names will be able to access live data.
There is no reason to both approve and block logon names.

 Note: If a username has ever been changed, you must block or approve the original username. For
example, if user "Smith" was originally user "John Smith," but the username was changed, you must block
"John Smith." Blocking "Smith" will not work. This is due to how Windows stores usernames.

To approve or block access to live data by a Windows logon name:

On the Options menu, click Settings....1. 
Click the Approved Users tab.2. 
Do one of the following:

To allow the newly added user to get live data, select the Name approved for live loop
monitoring checkbox.

♦ 

To prevent the newly added user from getting live data, clear the Name approved for live
loop monitoring checkbox.

♦ 

3. 

Type the logon name to be added into the Enter the user's logon name box and click Add Entry.4. 

 Note: If any logon names are approved, only approved logon names will be able to access live data.
There is no reason to both approve and block logon names.
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To remove a Windows logon name from the list of approved or blocked logon names:

On the Options menu, click Settings....1. 
Click the Approved Users tab2. 
In the Approved/blocked Users list, click the logon name.3. 
Click Delete.4. 

Restricting access to live data by IP address: IP addresses (or ranges of IP addresses) can be either
blocked or approved. If any IP addresses are approved, only IP addresses that are both approved and not
blocked will be able to access live data. Using this feature, it is possible to approve a range of IP addresses
but block some addresses in that range.

 Note: There is an exception to the rule that only IP addresses that are both approved and not blocked
can access live data. If you block a range of IP addresses and then approve a single IP address in that
range, you will be able to get live data from that single address. This makes it possible to block a range of IP
addresses but allow access from specific computers in that range.

To approve or block live data access from a single IP address:

On the Options menu, click Settings....1. 
Click the Approved IP addresses tab2. 
In the From boxes, type the IP address. It will appear in the To boxes as you type.3. 
Do one of the following:

To allow the IP address to access live data, select the Range approved for live loop
monitoring checkbox.

♦ 

To block the IP address from accessing live data, clear the Range approved for live loop
monitoring checkbox.

♦ 

4. 

Click Add Entry.5. 

To approve or block live data access from a range of IP addresses:

On the Options menu, click CIUMon Settings.1. 
Click the Approved IP addresses tab2. 
In the From boxes, type the first IP address in the range.3. 
In the To boxes, type the last IP address in the range.4. 
Do one of the following:

To allow IP addresses in the range to access live data, select the Range approved for live
loop monitoring checkbox.

♦ 

To block IP addresses in the range from accessing live data, clear the Range approved for
live loop monitoring checkbox.

♦ 

5. 

Click Add Entry.6. 

To change an IP address or range of IP addresses in the list of approved or blocked IP ranges:

On the Options menu, click CIUMon Settings.1. 
Click the Approved IP addresses tab2. 
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In the Range of approved IP addresses box, click the IP address or range that you would like to
change.

3. 

Click Edit.4. 
Make any changes you want to this IP address or range. For example, you can change whether the
IP address is approved or blocked. Then, click OK.

5. 

To remove an IP address or range of IP addresses from the list of approved or blocked IP ranges:

On the Options menu, click CIUMon Settings.1. 
Click the Approved IP addresses tab2. 
In the Range of approved IP addresses box, click the IP address or range.3. 
Click Delete.4. 

5.10.2 Tracking who is using live data

CIUMon has two options for tracking usage. Communication statistics and usage statistics track slightly
different information. They each provide a summary report and a detailed report, which display different
information. These reports can be accessed through the Options menu. Statistics from both types of usage
tracking can be saved to a file.

5.10.3 Allowing some users to get more live data than others
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One way to deal with the limitations on how much live data you can get is to give some users more live data
than others, by assigning them a higher user weight. For instance, a user with a user weight of two will get
twice as much data as a user with a user weight of one. By default, all users have a user weight of one.

To assign a user weight:

On the Options menu, click CIUMon Settings.1. 
Click the User Weights tab.2. 
Type the user's logon name in the Enter the user's logon name box.3. 
In the User Weight list, click the user weight to be assigned.4. 
Click Add Entry.5. 

To delete an assigned user weight:

On the Options menu, click CIUMon Settings.1. 
Click the User Weights tab.2. 
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In the User Weights list, click the user weight to be deleted.3. 
Click Delete.4. 
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